re = /(\?[^?]*)+/
str = 'localhost.com/en_ar/body?abcd?products_type=235&treatment=132?product_type=235&treatment=132&__from_store=en_bh'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result