#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*Amount:\s*(\d+)"
Local $sString = "Date:21" & @CRLF & _
"Month:03" & @CRLF & _
"Year:2017" & @CRLF & _
"Amount:50" & @CRLF & _
"Category:Wow" & @CRLF & _
"Account:The" & @CRLF & _
"Note:This"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")