import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*Amount:\\s*(\\d+)";
final String string = "Date:21\n"
+ "Month:03\n"
+ "Year:2017\n"
+ "Amount:50\n"
+ "Category:Wow\n"
+ "Account:The\n"
+ "Note:This";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}