// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*Amount:\s*(\d+)").unwrap();
let string = "Date:21
Month:03
Year:2017
Amount:50
Category:Wow
Account:The
Note:This";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}