const regex = /\s*Amount:\s*(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*Amount:\\s*(\\d+)', 'g')
const str = `Date:21
Month:03
Year:2017
Amount:50
Category:Wow
Account:The
Note:This`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}