using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*Amount:\s*(\d+)";
string input = @"Date:21
Month:03
Year:2017
Amount:50
Category:Wow
Account:The
Note:This";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}