re = /\s*Amount:\s*(\d+)/
str = 'Date:21
Month:03
Year:2017
Amount:50
Category:Wow
Account:The
Note:This'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end