package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*Amount:\s*(\d+)`)
var str = `Date:21
Month:03
Year:2017
Amount:50
Category:Wow
Account:The
Note:This`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}