#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)export type \w+ =(?: (\S+))?(?:\s+\| (\S+))*;"
Local $sString = "export type RegistrationMode = "Closed" | "RequireApplication" | "Open";" & @CRLF & _
"" & @CRLF & _
"export type SearchType =" & @CRLF & _
" | "All"" & @CRLF & _
" | "Comments"" & @CRLF & _
" | "Posts"" & @CRLF & _
" | "Communities"" & @CRLF & _
" | "Users"" & @CRLF & _
" | "Url";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")