re = /export type \w+ =(?: (\S+))?(?:\s+\| (\S+))*;/m
str = 'export type RegistrationMode = "Closed" | "RequireApplication" | "Open";
export type SearchType =
| "All"
| "Comments"
| "Posts"
| "Communities"
| "Users"
| "Url";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end