using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"export type \w+ =(?: (\S+))?(?:\s+\| (\S+))*;";
string input = @"export type RegistrationMode = ""Closed"" | ""RequireApplication"" | ""Open"";
export type SearchType =
| ""All""
| ""Comments""
| ""Posts""
| ""Communities""
| ""Users""
| ""Url"";";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}