import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "export type \\w+ =(?: (\\S+))?(?:\\s+\\| (\\S+))*;";
final String string = "export type RegistrationMode = \"Closed\" | \"RequireApplication\" | \"Open\";\n\n"
+ "export type SearchType =\n"
+ " | \"All\"\n"
+ " | \"Comments\"\n"
+ " | \"Posts\"\n"
+ " | \"Communities\"\n"
+ " | \"Users\"\n"
+ " | \"Url\";";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}