const regex = new RegExp('export type \\w+ =(?: (\\S+))?(?:\\s+\\| (\\S+))*;', 'gms')
const str = `export type RegistrationMode = "Closed" | "RequireApplication" | "Open";
export type SearchType =
| "All"
| "Comments"
| "Posts"
| "Communities"
| "Users"
| "Url";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}