package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)export type \w+ =(?: (\S+))?(?:\s+\| (\S+))*;`)
var str = `export type RegistrationMode = "Closed" | "RequireApplication" | "Open";
export type SearchType =
| "All"
| "Comments"
| "Posts"
| "Communities"
| "Users"
| "Url";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}