package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z\d]{8}-[a-zA-Z\d]{4}-[a-zA-Z\d]{8}-[a-zA-Z\d]{12})`)
var str = `23311544-6311-43f4abd5-7e96ceaa29f2`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}