re = /([a-zA-Z\d]{8}-[a-zA-Z\d]{4}-[a-zA-Z\d]{8}-[a-zA-Z\d]{12})/m
str = '23311544-6311-43f4abd5-7e96ceaa29f2'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result