$re = '/([a-zA-Z\d]{8}-[a-zA-Z\d]{4}-[a-zA-Z\d]{8}-[a-zA-Z\d]{12})/m';
$str = '23311544-6311-43f4abd5-7e96ceaa29f2';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;