import re
regex = re.compile(r"([a-zA-Z\d]{8}-[a-zA-Z\d]{4}-[a-zA-Z\d]{8}-[a-zA-Z\d]{12})", flags=re.MULTILINE)
test_str = "23311544-6311-43f4abd5-7e96ceaa29f2"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)