const regex = /([a-zA-Z\d]{8}-[a-zA-Z\d]{4}-[a-zA-Z\d]{8}-[a-zA-Z\d]{12})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z\\d]{8}-[a-zA-Z\\d]{4}-[a-zA-Z\\d]{8}-[a-zA-Z\\d]{12})', 'gm')
const str = `23311544-6311-43f4abd5-7e96ceaa29f2`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);