# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\. #([^\\.]*)$/./gm;t' <<< "#abc #def This is a test paragraph. #ads I only want to remove the hashtags after the full stop at the end and keep the hashtag at the center. These hashtags should be removed. #ads #ime #abc"