using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\. #([^\\.]*)$";
string substitution = @".";
string input = @"#abc #def This is a test paragraph. #ads I only want to remove the hashtags after the full stop at the end and keep the hashtag at the center. These hashtags should be removed. #ads #ime #abc";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}