use strict;
my $str = '#abc #def This is a test paragraph. #ads I only want to remove the hashtags after the full stop at the end and keep the hashtag at the center. These hashtags should be removed. #ads #ime #abc';
my $regex = qr/\. #([^\\.]*)$/mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";