// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\. #([^\\.]*)$").unwrap();
let string = "#abc #def This is a test paragraph. #ads I only want to remove the hashtags after the full stop at the end and keep the hashtag at the center. These hashtags should be removed. #ads #ime #abc";
let substitution = ".";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}