package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\. #([^\\.]*)$`)
var str = `#abc #def This is a test paragraph. #ads I only want to remove the hashtags after the full stop at the end and keep the hashtag at the center. These hashtags should be removed. #ads #ime #abc`
var substitution = "."
fmt.Println(re.ReplaceAllString(str, substitution))
}