package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<a(.*?)href=('|\")([^\>]*).(jpe?g|png|gif|mp4|webp|bmp)('|\")(.*?)>`)
var str = `<a href="https://localhost/test" target="_blank">TEST</a>
<a href="http://localhost/test.jpg" data-fancybox="fancybox" data-caption="">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/te.2er44.-.awd.wd.ddwadst.jpg">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/test.svg">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/test.gif">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}