// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<a(.*?)href=('|\")([^\>]*).(jpe?g|png|gif|mp4|webp|bmp)('|\")(.*?)>"#).unwrap();
let string = "<a href=\"https://localhost/test\" target=\"_blank\">TEST</a>
<a href=\"http://localhost/test.jpg\" data-fancybox=\"fancybox\" data-caption=\"\">
<img src=\"https://localhost/test-400x400.jpg\" alt=\"\">
</a>
<a href=\"https://localhost/te.2er44.-.awd.wd.ddwadst.jpg\">
<img src=\"https://localhost/test-400x400.jpg\" alt=\"\">
</a>
<a href=\"https://localhost/test.svg\">
<img src=\"https://localhost/test-400x400.jpg\" alt=\"\">
</a>
<a href=\"https://localhost/test.gif\">
<img src=\"https://localhost/test-400x400.jpg\" alt=\"\">
</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}