import Foundation
let pattern = #"<a(.*?)href=('|\")([^\>]*).(jpe?g|png|gif|mp4|webp|bmp)('|\")(.*?)>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<a href="https://localhost/test" target="_blank">TEST</a>
<a href="http://localhost/test.jpg" data-fancybox="fancybox" data-caption="">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/te.2er44.-.awd.wd.ddwadst.jpg">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/test.svg">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/test.gif">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)