const regex = /<a(.*?)href=('|\")([^\>]*).(jpe?g|png|gif|mp4|webp|bmp)('|\")(.*?)>/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a(.*?)href=(\'|\\")([^\\>]*).(jpe?g|png|gif|mp4|webp|bmp)(\'|\\")(.*?)>', 'ig')
const str = `<a href="https://localhost/test" target="_blank">TEST</a>
<a href="http://localhost/test.jpg" data-fancybox="fancybox" data-caption="">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/te.2er44.-.awd.wd.ddwadst.jpg">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/test.svg">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/test.gif">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}