use strict;
my $str = '<a href="https://localhost/test" target="_blank">TEST</a>
<a href="http://localhost/test.jpg" data-fancybox="fancybox" data-caption="">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/te.2er44.-.awd.wd.ddwadst.jpg">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/test.svg">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>
<a href="https://localhost/test.gif">
<img src="https://localhost/test-400x400.jpg" alt="">
</a>';
my $regex = qr/<a(.*?)href=('|\")([^\>]*).(jpe?g|png|gif|mp4|webp|bmp)('|\")(.*?)>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}