#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(o(?1)?o)"
Local $sString = "" & @CRLF & _
"o" & @CRLF & _
"oo" & @CRLF & _
"ooo" & @CRLF & _
"oooo" & @CRLF & _
"ooooo" & @CRLF & _
"oooooo" & @CRLF & _
"ooooooo 7" & @CRLF & _
"oooooooo 8" & @CRLF & _
"ooooooooo 9" & @CRLF & _
"oooooooooo 10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")