using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(o(?1)?o)";
string input = @"
o
oo
ooo
oooo
ooooo
oooooo
ooooooo 7
oooooooo 8
ooooooooo 9
oooooooooo 10";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}