import re
regex = re.compile(r"(o(?1)?o)")
test_str = ("\n"
"o\n"
"oo\n"
"ooo\n"
"oooo\n"
"ooooo\n"
"oooooo\n"
"ooooooo 7\n"
"oooooooo 8\n"
"ooooooooo 9\n"
"oooooooooo 10")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")