import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(o(?1)?o)";
final String string = "\n"
+ "o\n"
+ "oo\n"
+ "ooo\n"
+ "oooo\n"
+ "ooooo\n"
+ "oooooo\n"
+ "ooooooo 7\n"
+ "oooooooo 8\n"
+ "ooooooooo 9\n"
+ "oooooooooo 10";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}