$re = '/(o(?1)?o)/';
$str = '
o
oo
ooo
oooo
ooooo
oooooo
ooooooo 7
oooooooo 8
ooooooooo 9
oooooooooo 10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);