using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<no>{{[\w ]+}})|(?<yes>{?[\w .]*}?)";
string input = @"test{{this should not be selected and the curly brackets too}} but this one { or } should be selected. So {I} want {{to}} exclude all text between an opening and closing curly brackets.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}