package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<no>{{[\w ]+}})|(?<yes>{?[\w .]*}?)`)
var str = `test{{this should not be selected and the curly brackets too}} but this one { or } should be selected. So {I} want {{to}} exclude all text between an opening and closing curly brackets.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}