$re = '/(?<no>{{[\w ]+}})|(?<yes>{?[\w .]*}?)/';
$str = 'test{{this should not be selected and the curly brackets too}} but this one { or } should be selected. So {I} want {{to}} exclude all text between an opening and closing curly brackets.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);