// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<no>{{[\w ]+}})|(?<yes>{?[\w .]*}?)").unwrap();
let string = "test{{this should not be selected and the curly brackets too}} but this one { or } should be selected. So {I} want {{to}} exclude all text between an opening and closing curly brackets.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}