re = /(?<no>{{[\w ]+}})|(?<yes>{?[\w .]*}?)/
str = 'test{{this should not be selected and the curly brackets too}} but this one { or } should be selected. So {I} want {{to}} exclude all text between an opening and closing curly brackets.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end