const regex = /(?<no>{{[\w ]+}})|(?<yes>{?[\w .]*}?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<no>{{[\\w ]+}})|(?<yes>{?[\\w .]*}?)', 'g')
const str = `test{{this should not be selected and the curly brackets too}} but this one { or } should be selected. So {I} want {{to}} exclude all text between an opening and closing curly brackets.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}