import Foundation
let pattern = #"(?<no>{{[\w ]+}})|(?<yes>{?[\w .]*}?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"test{{this should not be selected and the curly brackets too}} but this one { or } should be selected. So {I} want {{to}} exclude all text between an opening and closing curly brackets."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)