using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bPAR1234\b|\bPAR\b.*\b1234\b";
string input = @"PAR1234
PAR 1234
PAR 5678, 1234
PAR 9991234999, 1234
PAR !@#-= 1234
PAR1234-122
PAR#1234-233
ANY TEXT PAR#1234-233
PART 1234
APART 1234
PAR 1234999
PAR 9991234
PAR 9991234999
1234 PAR ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}