import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bPAR1234\\b|\\bPAR\\b.*\\b1234\\b";
final String string = "PAR1234\n"
+ "PAR 1234\n"
+ "PAR 5678, 1234\n"
+ "PAR 9991234999, 1234\n"
+ "PAR !@#-= 1234\n"
+ "PAR1234-122\n"
+ "PAR#1234-233\n"
+ "ANY TEXT PAR#1234-233\n\n\n"
+ "PART 1234 \n"
+ "APART 1234 \n"
+ "PAR 1234999 \n"
+ "PAR 9991234 \n"
+ "PAR 9991234999 \n"
+ "1234 PAR ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}