// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bPAR1234\b|\bPAR\b.*\b1234\b").unwrap();
let string = "PAR1234
PAR 1234
PAR 5678, 1234
PAR 9991234999, 1234
PAR !@#-= 1234
PAR1234-122
PAR#1234-233
ANY TEXT PAR#1234-233
PART 1234
APART 1234
PAR 1234999
PAR 9991234
PAR 9991234999
1234 PAR ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}