const regex = /\bPAR1234\b|\bPAR\b.*\b1234\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bPAR1234\\b|\\bPAR\\b.*\\b1234\\b', 'g')
const str = `PAR1234
PAR 1234
PAR 5678, 1234
PAR 9991234999, 1234
PAR !@#-= 1234
PAR1234-122
PAR#1234-233
ANY TEXT PAR#1234-233
PART 1234
APART 1234
PAR 1234999
PAR 9991234
PAR 9991234999
1234 PAR `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}