import Foundation
let pattern = #"\bPAR1234\b|\bPAR\b.*\b1234\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
PAR1234
PAR 1234
PAR 5678, 1234
PAR 9991234999, 1234
PAR !@#-= 1234
PAR1234-122
PAR#1234-233
ANY TEXT PAR#1234-233
PART 1234
APART 1234
PAR 1234999
PAR 9991234
PAR 9991234999
1234 PAR
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)