re = /\bPAR1234\b|\bPAR\b.*\b1234\b/
str = 'PAR1234
PAR 1234
PAR 5678, 1234
PAR 9991234999, 1234
PAR !@#-= 1234
PAR1234-122
PAR#1234-233
ANY TEXT PAR#1234-233
PART 1234
APART 1234
PAR 1234999
PAR 9991234
PAR 9991234999
1234 PAR '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end