# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bPAR1234\b|\bPAR\b.*\b1234\b"
test_str = ("PAR1234\n"
"PAR 1234\n"
"PAR 5678, 1234\n"
"PAR 9991234999, 1234\n"
"PAR !@#-= 1234\n"
"PAR1234-122\n"
"PAR#1234-233\n"
"ANY TEXT PAR#1234-233\n\n\n"
"PART 1234 \n"
"APART 1234 \n"
"PAR 1234999 \n"
"PAR 9991234 \n"
"PAR 9991234999 \n"
"1234 PAR ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.