using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^dev_[0-9]+(?:.[0-9]+)+$";
string input = @"dev_1.0
dev_1.1
dev_1.2
dev_1.2.3
dev_1.2.3.4
dev1.2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}