import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^dev_[0-9]+(?:.[0-9]+)+$";
final String string = "dev_1.0\n"
+ "dev_1.1\n"
+ "dev_1.2\n"
+ "dev_1.2.3\n"
+ "dev_1.2.3.4\n"
+ "dev1.2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}